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• 09:00 Introduction

• 09:30 PCB Design intro

• 09:45 PCB Soldering & electrical testing

• 10:45 PCB Test & bootloader

• 11:00 SW intro (OLED, I2C, ADCs, Interrupts)

• 12:00 Lunch break

• 12:30 SW intro (OLED, I2C, ADCs, Interrupts)

• 13:30 Develop simple game (Snake)

• 15:30 Download finished games
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Introduction

• Build a mini hand-held battery power arcade game 
console from scratch

• Specs:
• ATTiny85 controller (8K Bytes memory)

16 MHz

• OLED screen

• 5 push buttons (full D-pad + action button)

• On/off slide switch

• Piezo buzzer for sound effects

• CR2032 battery

• Through-hole PCB
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Introduction

• Credits!

Original implementation from Electronoobs

D-pad upgrade & most games from Daniel C.

Some games created by Andy Jackson

https://electronoobs.com/eng_arduino_tut120.php
https://www.tinyjoypad.com/tinyjoypad_attiny85
https://github.com/andyhighnumber/Attiny-Arduino-Games
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Introduction

• We’ll go over entire development:
• Schematic ➔ draw and manufacture PCB ➔ Soldering ➔ Electrical test ➔ SW test ➔

Software implementation of simple game

• PCB Design: EAGLE Layout Editor

• Software is written using Arduino IDE and language



• 17 supported games (one at a time ☺):
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Introduction

Space Invaders (1978)Frogger (1981)

Q*bert (1982) Arkanoid (1986) Excite Bike (1984)

Dugger (1988)

Bomberman (1983)

Tiny Gilbert (platformer)

https://www.youtube.com/watch?v=hkp_OjNX4Ss
https://www.youtube.com/watch?v=PtYDiMktu9M
https://www.youtube.com/watch?v=1lALQOw190M&feature=youtu.be
https://www.youtube.com/watch?v=dlDt-5oEnIw
https://youtu.be/TeqHoSFIo0U
https://youtu.be/0Dm1qFoj8GA
https://www.youtube.com/watch?v=0okr0_vsDwI
https://www.youtube.com/watch?v=yv-ZH0_JHi0


• 17 supported games (one at a time ☺):
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Introduction

Tetris (1984)Hat Trick (1988)

Morpion (tic-tac-toe) Pacman (1980) Pinball (1984)

Plaque Attack (1983)

Pipeline (1978)

Missile Command (1980)

Snake (1976)

https://youtu.be/ub3K0bkFh1c
https://youtu.be/PT78cFqzk-I
https://youtu.be/JWH-4wWavF8
https://www.youtube.com/watch?v=NwdJZ5ZICMM
https://www.youtube.com/watch?v=p6qU1dX1JiU
https://youtu.be/GQ1IJgQIZMA
https://youtu.be/galWVpOzRkk
https://youtu.be/orzP3zrHqCM


• 3D printed housing

• Not part of this workshop

• Fusion360 CAD software (free for students!) – Prusa MK3 printer
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Introduction



• Location of course files:

https://gitlab.com/EAVISE/workshops/

ATTinyArcadeV2

• Task 1:

• Download ZIP from course URL

• Contains these slides, PCB, datasheets, games, SW templates,…

• Extract to D:\ drive
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Introduction

https://gitlab.com/EAVISE/workshops/
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Introduction – ATTiny85 microcontroller
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Introduction - schematic
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Introduction - PCB



• Task 2:

• Use the datasheets to calculate the battery life of this mini handheld game console!
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Introduction
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Overview of today
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• Task 3:

• Copy folder “ATTinyArcade_PCB” (under hardware) to:

C:\Users\student\Documents\EAGLE\projects\

If folder does not exist yet, first open Eagle and login

• Open Eagle from desktop

If login is required:

“elektronicaworkshop@gmail.com”

pwd: “arduinoide1”

• Open project (both schematic and PCB – press F5 if not yet visible)
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PCB Design intro



• Task 4:

• Add the power LED and resistor to the schematic

• Position and route both the LED and resistor on the PCB

• Perform ERC and DRC check
• https://jlcpcb.com/capabilities/Capabilities

➔ Use the jlcpcb2layer.dru file

• Use the CAM generator to generate Gerber files
➔ Use the jlcpcb_2_layer_v9.cam file

• Upload Gerber files to your favorite PCB fab
➔ e.g. https://jlcpcb.com/

• View PCB preview and check for errors
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PCB Design intro

https://jlcpcb.com/capabilities/Capabilities
https://jlcpcb.com/
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• PCB for this workshop has been designed completely through hole

• Solder from lowest components to highest components

• Do not forget solder jumpers

• Note polarities and positions of components!

• After soldering we perform an electrical test

22

PCB Soldering
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PCB Soldering

See solder guide here:

https://gitlab.com/EAVISE/workshops/attinyarcadev2/-

/blob/main/SOLDER_GUIDE.md

https://gitlab.com/EAVISE/workshops/attinyarcadev2/-/blob/main/SOLDER_GUIDE.md
https://gitlab.com/EAVISE/workshops/attinyarcadev2/-/blob/main/SOLDER_GUIDE.md


• Move to lab A111

• Hope to finish around 10:45
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PCB Soldering
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• Let’s now burn the bootloader (set the fuses) and test the hardware of the 

board!

• Task 5
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PCB Test & bootloader



• First, install the ATTiny85 libraries

• Start Arduino IDE, go to File ➔ Preferences

Add an additional board manager URL:

https://raw.githubusercontent.com/damellis/attiny/ide-1.6.x-boards-

manager/package_damellis_attiny_index.json
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PCB Test & bootloader

https://raw.githubusercontent.com/damellis/attiny/ide-1.6.x-boards-manager/package_damellis_attiny_index.json
https://raw.githubusercontent.com/damellis/attiny/ide-1.6.x-boards-manager/package_damellis_attiny_index.json


• Tools ➔ Board ➔ Board manager

• Search for attiny, install the board:

• attiny (by David A. Mellis - version 1.0.2)
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PCB Test & bootloader



• Under Tools ➔ Board ➔ “Attiny Microcontrollers” should now be available
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PCB Test & bootloader



• We’re going to use the Arduino Uno as ISP programmer to program the 

ATTiny85 on our PCB, using the header at the back

• Connect the Arduino Uno to the PCB header as shown on next slide (do not 

connect the Uno through USB yet)

• Double check connections when finished

• Connect Arduino Uno to USB on desktop

30

PCB Test & bootloader
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PCB Test & bootloader

Arduino 

Uno

ATTiny85 

Arcade 

PCB

3V3 VCC

D11 MOSI

D12 MISO

D13 SCK

D10 RESET

GND GND



• Upload the Arduino ISP code to the Arduino Uno

• First, open the ISP code:

File ➔ Examples ➔ 11. ArduinoISP➔ ArduinoISP
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PCB Test & bootloader



• Select the correct board:

Tools ➔ Board 

(set to Arduino Uno)

Tools ➔ Port

(select correct COM port)

Tools ➔ Programmer

(select AVRISP mkII)

• Upload code to board!
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PCB Test & bootloader



• We can now use the Arduino Uno as ISP to program our ATTiny85 PCB

• First, we need to burn the bootloader (which sets the fuses)

34

PCB Test & bootloader



• Under Tools, make sure to select the following options:

Board: “ATTiny25/45/85”

Processor: “ATTiny85”

Clock: 16 MHz internal➔ EXTREMELY IMPORTANT
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PCB Test & bootloader



• Make sure to change Tools ➔ Programmer to Arduino as ISP

• Click on Tools ➔ Burn bootloader

• You should get: “Done burning bootloader” if everything went fine (and 

some beep noises ☺), otherwise check connections again
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PCB Test & bootloader



• We can now program the ATTiny85 from the Arduino IDE

• First, we run a simple hardware test program

• This runs the following sequence:

• Initialize ports of ATTiny85

• Initialize OLED screen

• Shows EAVISE logo (2 seconds)

• Plays sound

• Shows test screen to test D-pad and action button
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PCB Test & bootloader



• This sketch is found under “/software/hw_test/”

• Open in Arduino IDE, make sure that ATTiny85 board is still selected with 

16 MHz clock, and the programmer is Arduino as ISP

• Upload the code and test the hardware!

38

PCB Test & bootloader
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• Let’s now discuss the software side:

• The OLED screen interfacing

• I2C interface protocol

• User input

• ADCs

• Interrupts (optional)
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SW intro (OLED, I2C, ACD, Interrupts)



• OLED screen specs:

• SSD1306 controller

• Supports I2C & SPI

• 128 x 64 pixels

• 0.96-inch diagonal

• Supply voltage 3.3V – 5V
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SW intro (OLED)



• OLED technology:

• Similar to LED, emissive electroluminescent layer is a film of organic compound that 

emits light in response to an electric current

• PMOLED and AMOLED

42

SW intro (OLED)

https://www.unisystem-displays.com/en/news/all-about-oleds.html



• OLED technology:
• Each pixel emits visible light (as opposed to an LCD screen)

• Advantages:

• Excellent brightness and contrast

• Wide viewing-angle

• No need for backlight: smaller, lightweight, flexible, uses less power

• Fast response time

• Disadvantages:

• Expensive technology

• Limited lifetime of organic material

• Prone to environmental factors (e.g. moisture)
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SW intro (OLED)

https://www.unisystem-displays.com/en/news/all-about-oleds.html
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SW intro (OLED)

https://www.unisystem-displays.com/en/news/all-about-oleds.html



• Our screen uses I2C for communication with the SSD1306 controller:
• Inter-Integrated circuit bus

• Two wire interface: SCK & SDA: bidirectional and open-collector or open-drain (pull-up required)
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SW intro (I2C)

Texas Instruments - Application Report SLVA704–June 2015 Understanding the I2C Bus



• I2C

• Controller (master) communicates with slave devices

• Slave may not transmit data unless addressed

• Each device on the I2C bus has a specific address

• Many slave devices require configuration upon startup to set behavior

• Typically done through the slave’s internal register maps

• A device can have one or multiple registers where data is stored, written or read
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SW intro (I2C)

Texas Instruments - Application Report SLVA704–June 2015 Understanding the I2C Bus
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SW intro (I2C)

Texas Instruments - Application Report SLVA704–June 2015 Understanding the I2C Bus
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SW intro (I2C)

• I2C message

Texas Instruments - Application Report SLVA704–June 2015 Understanding the I2C Bus
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SW intro (I2C)

• OLED screen - SSD1306 implementation: datasheet p. 20

Note:

I2C address: 01111000 ➔ 0x78

Write data or command: 00000000 ➔ 0x00

01000000 ➔ 0x40



50

SW intro (OLED)

• Now we know how to send data

• What should we send to do what? ➔ Command table (p. 28 – 32)

• Different types: fundamental, scrolling, addressing, HW configuration, timing
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SW intro (OLED)

• How does the screen work?
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SW intro (OLED)

• Set address pointer for GDDRAM
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SW intro (OLED)

• Startup sequence
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SW intro (OLED)

• Let’s have a look how this is programmed in our Arduino IDE

• Task 6:

• Open “oled_driver.ino” in Arduino IDE

• Examine code, try to understand how it works

• Use the loop function to:
1. Initialize the screen

2. Clear the screen

3. Draw a one-pixel border around the screen

4. Write your name in the middle of the screen, using:
void ssd1306_char_f6x8(uint8_t x, uint8_t y, const char ch[])

5. Optional: move or scroll it across the screen? Experiment yourself!
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SW intro (User Input - ADC)

• Now we are going to read the user input buttons

• How many user IOs are there? How many pins on microcontroller?

• Schematic:



58

SW intro (User Input - ADC)

• We use a trick to reduce the required IO ports

• Often used in hardware design
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SW intro (User Input - ADC)

• We use different analog values through voltage dividers on the analog 

inputs of the ATTiny85

• ADCs to determine button press!

• How do they work on the ATTiny85?

• 4 channels, single 10-bit ADC

• Successive approximation
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SW intro (User Input - ADC)
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SW intro (User Input - ADC)
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SW intro (User Input - ADC)
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SW intro (User Input - ADC)

• A lot of settings!

• MUX, reference voltage, enables, pre-scaler, interrupts, how 10-bit is 

stored in 8-bit registers, mode of operation,…

• 5 registers!

• Luckily, Arduino libraries perform lots of abstraction:

analogReadResolution(10) ;

analogReference(DEFAULT);

analogRead(A0);
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SW intro (User Input - ADC)

• Task 7:

• Calculate the expected ADC values for each of the 4 buttons (up, down, 

left, right)

• Open “user_input.ino” in Arduino IDE

• Examine code, try to understand how it works

• Extend the code to:

1. Initialize the user IOs

2. Show the ADC values on the OLED screen

tip: itoa(); to convert int to char

3. Show which buttons were pressed
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• Reading buttons this way is not efficient

• Sometimes OK, when SW routine is very predictable (e.g. game console)

• Interrupt the running code to do something else

• (Very) short routines (no delays)!

• Internal or external

• Examples: timer, watchdog, keyboard, sensor, switch

SW intro (Interrupts - optional)



• ACTION button is on PCINT0 pin

• Two types in ATTiny85

• INT0 triggers a direct dedicated interrupt routine
• Rising or falling is set through register

• PCINT (Pin Change INTerrupt) triggers an interrupt routine if one of the PCINT pins are 
triggered. You have to check which pin and what change yourself in the interrupt routine
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SW intro (Interrupts - optional)
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SW intro (Interrupts - optional)

• INT0

void routine() {

YOUR CODE HERE
}

attachInterrupt(digitalPinToInterrupt(PIN_NUMBER), routine, RISING);

Note: not supported 

by all ATTiny-cores
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SW intro (Interrupts - optional)

• PCINT0_vect

Set registers yourself in setup() of Arduino code!

ISR(PCINT0_vect) { 

YOUR CODE HERE (check which pin and change)

}

PCMSK |= bit (PCINT0);
GIMSK |= 0b00100000;
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SW intro (Interrupts - optional)

• Finally, enable all interrupts

• sei(); or interrupts();

• cli(); or noInterrupts();
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SW intro (Interrupts - optional)

• Let’s have a look how this is programmed in our Arduino IDE

• Task 8 - optional:

• Extend “user_input.ino” with interrupt routine for the ACTION button

• Uncomment the previous code for ACTION button read
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Develop simple Snake game

• Final task 9:

• program a simple game: Snake

• Rules:

• Snake moves in one of four directions at each new timeframe

• Direction controlled by D-pad

• Bait randomly positioned on screen

• If bait is catched, length of the snake, score and speed increases

• At borders, snake reappears at the opposite side of the game grid

• Game over when snake collides with itself
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Develop simple Snake game

• How to start?

➔Develop flowchart of game

• This has already been done for you! Let’s have a look.
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Develop simple Snake game

• A skeleton code framework has already been developed for you

• You need to write specific functions

• Some are optional

• Let’s look at the Arduino code

• Download the skeleton code and run

• Generates startup

• Gives heartbeat and draws border
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Develop simple Snake game

• Render_game() explanation

• Game grid is 16 x 32

Stored in unsigned long screenBuffer[16];

= 4 bytes = 32 bits

• Screen is 64 x 128

Each game pixel is a 4 x 4 pixel on the OLED screen

1  1  1  1

1  1  1  1

1  1  1  1

1  1  1  1

1  1  1  1

1  0  0  1

1  0  0  1

1  1  1  1

1 pixel border
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Develop simple Snake game

• Render_game() converts the screenBuffer[16] variable to OLED pixels

• You only need do two things:

• Set a ‘1’ at each position in the screenBuffer for each segment of the snake and the 

single bait

• Indicate the position of the bait with two variables

• int baitX

• int baitY

• Note: allowed snake and bait positions are X: 0-31 and Y: 0-15
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Develop simple Snake game

• Let’s try this:

• Uncomment draw_snake() and upload

• Now it’s up to you!

• Task 9 begins: you are now going to implement the missing functions 

yourself

• One by one: upload after each (partly) adjusted function

• We’ll walk you through each function (don’t worry ☺)
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Develop simple Snake game (1)

• First, define a global variable to hold the current direction

• Byte: 0: up, 1: left, 2: down, 3: right
• Don’t forget to reset this variable in resetGame();

• Function checks if U/D/L/R was pressed, and changes the direction if needed

• Move in opposite direction not allowed!

• To test, print the current direction as text on the screen

• Upload to test if it works! ➔ any remaining issues?



• Move each segment of the snake in the right direction

• Use variables xPos[], yPos[] and len

• Tip: use case-statement since direction is unambiguous

• Don’t forget the borders of the screen!

• Note: valid xPos = 0 – 31, valid yPos = 0-15

• Upload! The snake should now move over the game grid
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Develop simple Snake game (2)



• Generate random positions for a new bait (preferably not on the edges)

• baitX: 1 – 30, baitY: 1 – 14

• Test if bait is not dropped on snake itself!

• Print baitX and baitY somewhere on the screen as test for now
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Develop simple Snake game (3)



• See if the snake catched the bait with its head

• Return Boolean true or false

• Increment score and len in this function

• Don’t forget to limit the len to maxLen

• You can play a sound if the bait is catched

playMusic(BaitMusic, 4);

• Do not upload yet, first fix next function
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Develop simple Snake game (4)
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Develop simple Snake game (5)

• Draw the bait in the screen buffer

• Set a ‘1’ at the correct location in the buffer

• Remember: render_game() knows the difference between bait and snake based 
on baitX and baitY

• Use function draw_snake() as example

• Extremely short function

• Upload and test! You should be able to play the game (without collision 
detection)
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Develop simple Snake game (6)

• See if the head of the snake collided with a segment of itself

• Return Boolean true or false
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Develop simple Snake game

• That’s it! The game is finished. Well done.

• We have some optional functions left (simple – intermediate – advanced 

expert):

• Simple! Draw the current score each frame in one of the corners of the 

screen
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Develop simple Snake game

• Intermediate!

• At startup of the game see if e.g. UP was held pressed for specific time 

(e.g. 2 seconds)

• Mute or unmute sound if this was the case

• Through global variable

• Use as condition in beep-function

• Display mute or sound on top of the screen at startup



• Advanced! Use EEPROM to store previous high score

• After game over, load the high score from EEPROM

• Compare with current score

If higher, display on screen and write new high score to EEPROM

• Tips: EEPROM.read(), EEPROM.write()

EEPROM is read/written per byte. Int is 2 bytes long
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Develop simple Snake game



• Expert!

• After game over, put ATTiny85 in sleep mode

• Wake up after interrupt (PCINT0)

• Steps: clear and switch off OLED screen, switch ADC off, then enable sleep 

mode and sleep. On power up from sleep switch ADC and OLED screen 

back on
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Develop simple Snake game



• Develop your own variations!

• Game over when you go out of the screen?

• You could for example use the ACTION button to let the snake jump 

over itself!
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Develop simple Snake game
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• Feel free to download any of the following finished games, found in the 

finished_games folder:
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Download finished games

Space Invaders (1978)Frogger (1981)

Q*bert (1982) Arkanoid (1986) Excite Bike (1984)

Dugger (1988)

Bomberman (1983)

Tiny Gilbert (platformer)

https://www.youtube.com/watch?v=hkp_OjNX4Ss
https://www.youtube.com/watch?v=PtYDiMktu9M
https://www.youtube.com/watch?v=1lALQOw190M&feature=youtu.be
https://www.youtube.com/watch?v=dlDt-5oEnIw
https://youtu.be/TeqHoSFIo0U
https://youtu.be/0Dm1qFoj8GA
https://www.youtube.com/watch?v=0okr0_vsDwI
https://www.youtube.com/watch?v=yv-ZH0_JHi0


• Feel free to download any of the following finished games, found in the 

finished_games folder:
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Introduction

Tetris (1984)Hat Trick (1988)

Morpion (tic-tac-toe) Pacman (1980) Pinball (1984)

Plaque Attack (1983)

Pipeline (1978)

Missile Command (1980)

Snake (1976)

https://youtu.be/ub3K0bkFh1c
https://youtu.be/PT78cFqzk-I
https://youtu.be/JWH-4wWavF8
https://www.youtube.com/watch?v=NwdJZ5ZICMM
https://www.youtube.com/watch?v=p6qU1dX1JiU
https://youtu.be/GQ1IJgQIZMA
https://youtu.be/galWVpOzRkk
https://youtu.be/orzP3zrHqCM


• A few online sources for other games:

• https://github.com/andyhighnumber/Attiny-Arduino-Games

• https://github.com/webboggles/AttinyArcade

• https://www.tinyjoypad.com/tinyjoypad_attiny85

• https://www.tinyjoypad.com/arduboy

• …

➔ Some require code modification or additional libraries (e.g. different pins for 

OLED, coded for fewer buttons, etc.)
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Download finished games

https://github.com/andyhighnumber/Attiny-Arduino-Games
https://github.com/webboggles/AttinyArcade
https://www.tinyjoypad.com/tinyjoypad_attiny85
https://www.tinyjoypad.com/arduboy
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• 10:45 PCB Test & bootloader

• 11:00 SW intro (OLED, I2C, ADCs, Interrupts)

• 12:00 Lunch break

• 12:30 SW intro (OLED, I2C, ADCs, Interrupts)

• 13:30 Develop simple game (Snake)

• 15:30 Download finished games

• 16:00 End

Overview of today

Hardware

Software

Software
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The end

• We hope you enjoyed this workshop!
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